Start a conversation

Why isn't the mysqli_connect () function working in PHP 8.0?

PHP 8.0 is available on NIC.UA hosting servers since February 2, 2021. This version has some features that are important to consider when choosing it.

For the mysqli_connect () function to work correctly with PHP 8.0, you need to enable the nd_mysqli extension in the hosting panel (check the box next to the extension as in the image below).

On hosting with DirectAdmin, extensions are managed in the "Select PHP Version" section, which is located in the "Tools" drop-down menu.

On hosting with cPanel, extensions are managed in the "Select PHP version" section, which is a sub-item in the "Software" section (how to get to this section can be found here).

If you have any questions or difficulties in setting up hosting, please contact support.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Alexey Momot

  2. Posted
  3. Updated

Comments