Розпочати розмову

Чому не працює функція mysqli_connect() в PHP 8.0?

З 2 лютого 2021 року на хостинг-серверах NIC.UA стало доступною для використання PHP версії 8.0. Дана версія має деякі особливості, які варті враховувати при її обранні.

Для коректної роботи функції mysqli_connect() з PHP 8.0 необхідно активувати розширення nd_mysqli в панелі хостингу (встановіть прапорець біля розшірення як на зображенні нижче).

На хостингу з DirectAdmin керування розширеннями виконується в розділі  "Select PHP Version", який знаходиться в пукнті меню "Инструменты" (детальніше можете ознайомитися у цій статті).

На хостингу з cPanel керування розширеннями виконується в розділі "Вибір версії PHP", який знаходиться в складі розділу "Програмне забезпечення" (як потрапити у цей розділ можете ознайомитися у цій статті).

Якщо виникнуть питання або складнощі в налаштуваннях, будь ласка, зверніться до підтримки.

Вибрати файли або перетягніть файли
Це допомогло?
Так
Ні
  1. Alexey Momot

  2. Опубліковано
  3. Оновлено

Коментарі